[SOLVED] table reaches maximum database

9 years 5 months ago #127006 by darb
I have an problem installing a new plg with new CB 1.2.2 looks like this issue again...

http://www.joomlapolis.com/component/option,com_joomlaboard/Itemid,/func,view/catid,64/id,78961/#78961

This is error message I got:

SQL error on field store2: moscomprofilerFields::store failed: CBSQLupgrader::changeColumn (ADD) of Table #__comprofiler Column confirmemail failed with SQL error: Row size too large. The maximum row size for the used table type, not counting BLOBs, is 65535. You have to change some columns to TEXT or BLOBs SQL=ALTER TABLE `jos_comprofiler`\\n ADD `confirmemail` varchar(255) DEFAULT NULL Row size too large. The maximum row size for the used table type, not counting BLOBs, is 65535. You have to change some columns to TEXT or BLOBs SQL=ALTER TABLE `jos_comprofiler`\\n ADD `confirmemail` varchar(255) DEFAULT NULL

Post edited by: krileon, at: 2010/05/12 21:19
9 years 5 months ago #127069 by krileon
Please review Beats reply in the thread you provided. This is the only fix. This is a limitation of MYSQL and there is absolutely no workaround. We're working on for CB 2.0 to have a better method for storing fields so you no longer run into this issue. As is however you're limited to roughly 100-150 fields depending on what type they are.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Templates - CBSubs - Hosting - Forge - Incubator - GroupJive
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM EST to 4:00 PM EST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.
9 years 4 months ago #127727 by jakobe75
I just got this error today as well. (3/2010)

Then upon my research to fix, I found I have reached the max number of fields.

the fix posted mentioned it will be fixed in the next version (that was 2008 btw)

I am running 1.2.2

The fix posted asks you to edit file

components/com_comprofiler/plugin/user/cb.core.xml

I dont have this file

although I do have

components/com_comprofiler/plugin/user/plug_cbcore/cb.core.xml

Should I edit the code
varchar (255) in that file?

suggestions?

Post edited by: jakobe75, at: 2010/03/22 23:30
9 years 4 months ago #127796 by krileon
jakobe75 wrote:

I just got this error today as well. (3/2010)

Then upon my research to fix, I found I have reached the max number of fields.

the fix posted mentioned it will be fixed in the next version (that was 2008 btw)

I am running 1.2.2

The fix posted asks you to edit file

components/com_comprofiler/plugin/user/cb.core.xml

I dont have this file

although I do have

components/com_comprofiler/plugin/user/plug_cbcore/cb.core.xml

Should I edit the code
varchar (255) in that file?

suggestions?

Post edited by: jakobe75, at: 2010/03/22 23:30

The path was a minor typo of course the path you suggested is correct. You're welcome to attempt to fix it as you see fit, but there is no guarantees. We're working on a new method for CB 2.0 to handle fields better so there won't be such a limit anymore. You could also manually edit your database and change their types to something which uses less KBs per field.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Templates - CBSubs - Hosting - Forge - Incubator - GroupJive
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM EST to 4:00 PM EST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.
9 years 4 months ago #127807 by jakobe75
I havent tested, as I just deleted some testing fields.
and that eliminated the error

but I hope it works, I have about 35 text type fields each for 6 different user types, and I got this message only on my 3rd user/sub type.


will post progress.

thanks
9 years 4 months ago #128839 by jakobe75
I have tried several solutions found on the forum for this but I still cannot add anymore fields.

I really dont have alot of fields as yet
my field count in fields manager is at 90


this is only about 75% of the fields I need to continue.

This is my error:

[code:1]moscomprofilerFields::«»store failed: CBSQLupgrader::changeColumn (ADD) of Table #__comprofiler Column cb_elite2confirm failed with SQL error: Row size too large. The maximum row size for the used table type, not counting BLOBs, is 65535. You have to change some columns to TEXT or BLOBs SQL=ALTER TABLE `jos_comprofiler`\n ADD `cb_elite2confirm` varchar(255) DEFAULT NULL Row size too large. The maximum row size for the used table type, not counting BLOBs, is 65535. You have to change some columns to TEXT or BLOBs SQL=ALTER TABLE `jos_comprofiler`\n ADD `cb_elite2confirm` varchar(255) DEFAULT NULL[/code:1]


I am not sure if this is the same error other users where getting in the other threads.

I have tried this fix:

www.joomlapolis.com/component/option,com_joomlaboard/Itemid,/func,view/catid,64/id,78961/#78961


thus resulting in this file: (components/com_comprofiler/plugin/user/cb.core.xml)


[code:1]
</params>
</field>
<field type="text" label="Text Field">
<data name="" nametype="namesuffix" type="text" null="true" default="NULL" strict="false" />
<params>[/code:1]


When running the CB tools I get a ton of errors, so I did a dry run and nothing was fixed. (still red)

I also tried to change from varchar(255)
to varchar(125)

Based on suggestions in this thread:
www.joomlapolis.com/component/option,com_joomlaboard/Itemid,/func,view/catid,112/id,126433/#126433

I am still getting the error when adding any type of field.

how to fix?
or a workaround, as this is crippling me.

Post edited by: krileon, at: 2010/04/01 17:35
Moderators: beatnantkrileon
Time to create page: 0.433 seconds
Facebook Twitter Google LinkedIn