[SOLVED] connection emails - nn

10 years 2 months ago - 9 years 5 months ago #131696 by chaosnet
[SOLVED] connection emails - nn was created by chaosnet
Hi one and all,

decided to activate connections, and all is working fine other than the emails that are being sent are full of n's rather than breaks etc

So, when a connection is requested we're getitng this:

You have a pending connection from user2!

NOTE: This is a message generated automatically by the Connections system. It has the connecting user's address, so you can conveniently reply if you wish to.nnuser1 is requesting to connect with you and requires your approval. Please accept or deny the connection request accordingly. user1 included the following personal message:n
n
Hi mate, just testing n

Manage Connectionsn


And when the connection is approved we're seeing this:

NOTE: This is a message generated automatically by the Connections system. It has the connecting user's address, so you can conveniently reply if you wish to.nnYour request to connect with user2 was accepted!n

Manage Connectionsn


Any ideas on how to sort this small yet annoying bug?

CB 1.2.2 / UddeIm / J1.5.9

Ta

Please Log in to join the conversation.

10 years 2 months ago #131747 by krileon
Replied by krileon on topic Re:connection emails - nn

J1.5.9

Please first upgrade to 1.5.16 as you're multiple versions behind and this could be the culprit. Was not able to duplicate your issue however. You may want to review the connection email language string found at the following location to ensure it is correct.

IN: components/com_comprofiler/plugin/language/default_language/
ON: Line 395
[code:1]
DEFINE('_UE_SENDPMSNOTICE','NOTE: This is a message generated automatically by the Connections system. It has the connecting user\'s address, so you can conveniently reply if you wish to.');
[/code:1]

ON: Line 544
[code:1]
DEFINE('_UE_CONNECTIONPENDMSG','%s is requesting to connect with you and requires your approval. Please accept or deny the connection request accordingly.');
[/code:1]


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in to join the conversation.

9 years 8 months ago #144162 by mtupstairs
Replied by mtupstairs on topic Re:connection emails - nn
I posted in the UddeIM forum by mistake as he states this is not a UddeIM issue. Sorry about that one. However, I am still baffled by this and I can't find a post that actually has an answer. I am having this problem as well and the file you suggest looking at does not appear to have any issues to me. Any help would be appreciated. I can't track this one down and it makes a site look very poor.

Rob

Damn it Jim, I'm a pool player not a programmer!

Please Log in to join the conversation.

9 years 8 months ago #144166 by nant
Replied by nant on topic Re:connection emails - nn
mtupstairs wrote:

I posted in the UddeIM forum by mistake as he states this is not a UddeIM issue. Sorry about that one. However, I am still baffled by this and I can't find a post that actually has an answer. I am having this problem as well and the file you suggest looking at does not appear to have any issues to me. Any help would be appreciated. I can't track this one down and it makes a site look very poor.

Rob


Did you try what was suggested?

Please Log in to join the conversation.

9 years 8 months ago #144721 by mtupstairs
Replied by mtupstairs on topic Re:connection emails - nn
Sorry for the delay, as I stated I had posted this in the wrong forum twice and this was one of the wrong ones since I am on the latest version. But since you asked, my answer is "I think so". I did find those lines but I can't honestly say I would know what is correct. I compared them to what was posted, assuming it was correct, and mine matches. Well, with one exception on line 395 my code has the closing single quote but I believe it needs to be there.

Also, in your response to my post in 1.2.3 forum you state this is a known issue that will be addressed in the next release. Is that still the case or is there something I can do now?

Rob

Damn it Jim, I'm a pool player not a programmer!

Please Log in to join the conversation.

9 years 8 months ago #144800 by krileon
Replied by krileon on topic Re:connection emails - nn

Also, in your response to my post in 1.2.3 forum you state this is a known issue that will be addressed in the next release. Is that still the case or is there something I can do now?

Display of n or rn in place of linebreaks is a known issue with CB, we're working to address this with next release.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in to join the conversation.

Moderators: beatnantkrileon
Time to create page: 0.453 seconds

Facebook Twitter LinkedIn