[SOLVED] Multicheckbox-Problem in IE8

9 years 6 months ago #133287 by siegfriedp
Hello,

i have a registration-form which countains a Multicheckbox with three options. An input is required. In FF 3.6 all works fine, in IE8 the validation send an error that there is an input required - if one or more checkboxes are selected or not. Is there a solution for this issue?

best regards
Siegfried

Post edited by: krileon, at: 2010/05/20 16:55
9 years 6 months ago #133295 by krileon
siegfriedp wrote:

Hello,

i have a registration-form which countains a Multicheckbox with three options. An input is required. In FF 3.6 all works fine, in IE8 the validation send an error that there is an input required - if one or more checkboxes are selected or not. Is there a solution for this issue?

best regards
Siegfried

You've a required multi-checkbox field, correct? Is your IE8 up to date? What happens in IE7 compatibility mode? Are there any JS errors within error console? Is only multi-checkboxes not validating? Is issue present when using default Joomla template? Have you followed debug procedures found within Help Us Help You of my signature.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Templates - CBSubs - Hosting - Forge - Incubator - GroupJive
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM EST to 4:00 PM EST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.
9 years 6 months ago #133318 by siegfriedp
You've a required multi-checkbox field, correct? --> Yes
Is your IE8 up to date? -->Yes
What happens in IE7 compatibility mode? --> the same
Are there any JS errors within error console? --> I see no JS-Errors

Is only multi-checkboxes not validating? -->Yes
Is issue present when using default Joomla template?
-->With the default template it seems working. I use the Quasar-Template from Rockettheme
Have you followed debug procedures found within

Thanks for the quick response. I had debugged - but i am not so sure in JS

You can take a look on my form:
www.lcolympia.de/index.php/mylco/mitgliedwerden

When you hit the button you get a lot of Information about missing input. The field has the Text "Sportart" (near the bottom). You get the Required-Message if is filled or not.

best regards
Siegfried
9 years 6 months ago #133383 by krileon

With the default template it seems working. I use the Quasar-Template from Rockettheme

This is your problem then, your template likely has a JS conflict with the JS validation code. This means there is a JS error present. Very likely there is JS in the template that is not compatible with IE, but works fine in FF (this happens often). Please contact the developers of your template for further assistance.

Post edited by: krileon, at: 2010/05/18 17:54


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Templates - CBSubs - Hosting - Forge - Incubator - GroupJive
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM EST to 4:00 PM EST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.
9 years 6 months ago #133454 by siegfriedp
Hello Kyle,

unfortunately its only possible to ask questions in the rockettheme-forum when i am a member. yesterday i had debugged the script code and it seems that the form has no values in the script. I had changed the field to not required - but the field in the database is empty.

I will look for a workaround - i think single checkboxes will do this. by the way - what is the functionality of the field cbactivation? New registered peoplewill have there a guid-value.

Siegfried
9 years 6 months ago #133462 by nant
siegfriedp wrote:

Hello Kyle,

unfortunately its only possible to ask questions in the rockettheme-forum when i am a member. yesterday i had debugged the script code and it seems that the form has no values in the script. I had changed the field to not required - but the field in the database is empty.

I will look for a workaround - i think single checkboxes will do this. by the way - what is the functionality of the field cbactivation? New registered peoplewill have there a guid-value.

Siegfried


So how did you get the template if you are not a member?
Moderators: beatnantkrileon
Time to create page: 0.444 seconds
Facebook Twitter Google LinkedIn