Skip to Content Skip to Menu

Captcha image there but no letters!

  • Riba
  • Riba
  • OFFLINE
  • Posts: 12
  • Thanks: 0
  • Karma: 0
12 years 3 months ago #192150 by Riba
After updating a couple of packages on the web server the captcha stopped working - it generates the image but the letters are missing.
I tried changing fonts, I also suspected that the type library might be broken, but third part scripts that use the same library work fine and generate text. Plugin version 2.4 and CB 1.7.1.

Any ideas??

Please Log in or Create an account to join the conversation.

  • koengland
  • koengland
  • OFFLINE
  • Posts: 3
  • Thanks: 0
  • Karma: 0
12 years 3 months ago #192254 by koengland
Replied by koengland on topic Re: Captcha image there but no letters!
I've suddenly started experiencing this too.

Joomla version 1.5 CB captcha version 2.3

Please Log in or Create an account to join the conversation.

  • Riba
  • Riba
  • OFFLINE
  • Posts: 12
  • Thanks: 0
  • Karma: 0
12 years 3 months ago #192277 by Riba
Replied by Riba on topic Re: Captcha image there but no letters!
I guess I am glad to know I ma not the only one. :) I can confirm this problem both with the older plugin version. It seems to be something server related, but I can't put my finger on it, because both the type and graphic libraries work fine if tested. :(

Please Log in or Create an account to join the conversation.

  • nant
  • nant
  • ONLINE
  • Posts: 25532
  • Thanks: 1834
  • Karma: 877
12 years 3 months ago #192282 by nant
Replied by nant on topic Re: Captcha image there but no letters!
GD and freetype libraries need to be installed - the captcha plugin has some self=checks in backend for these 2 elements

Please Log in or Create an account to join the conversation.

  • Riba
  • Riba
  • OFFLINE
  • Posts: 12
  • Thanks: 0
  • Karma: 0
12 years 3 months ago #192284 by Riba
Replied by Riba on topic Re: Captcha image there but no letters!
As I mentioned, both are installed and work if tested by third party scripts.

Please Log in or Create an account to join the conversation.

  • nant
  • nant
  • ONLINE
  • Posts: 25532
  • Thanks: 1834
  • Karma: 877
12 years 2 months ago #192337 by nant
Replied by nant on topic Re: Captcha image there but no letters!

Riba wrote: As I mentioned, both are installed and work if tested by third party scripts.


Please give screenshot of captcha backend parameter area and please share what third party scripts are working?

My best guess is that your hoster upgraded to a bad version.

Please Log in or Create an account to join the conversation.

Moderators: beatnantkrileon
Powered by Kunena Forum

Facebook Twitter LinkedIn