[SOLVED] Unnamed User Profile re-visited

9 years 3 months ago #139429 by Word Warrior
In reference to this thread www.joomlapolis.com/index.php?option=com_joomlaboard&Itemid=38&func=view&id=102815&catid=78&limit=6&limitstart=0

I too had been having issues of exactly the same nature and it was increasingly driving me nuts!
I did as the thread said, took the bull by the horns and dived into the database using my admin.

It worked:woohoo:

Now, I'm by no means certain why those tables were there but I think it is possible that a previous incarnation of Community Builder may have left them there despite my Uninstalling CB a couple of years ago.

History:
I had Joomla 1.0.x and CB up and running and all worked fine, if a a little imperfect (my fault)
I moved to Joomla 1.5 and ran CB in Legacy mode for a while but needed to ditch legacy (for reasons I can no longer recall)
Of course the older version of CB would not run and caused me some problems so I uninstalled it and all it's modules etc.

I've always wanted to use CB as it seems to be the only one to fit my needs (Maybe should be integrated into Joomla??) v1.2.3 hit the streets and so I took the plunge. I must say installing it was a chore (maybe because of said tables still lurking in the DB from the past?) but I eventually got it to work but with the unnamed user issue.

Happy to say that most of it is working but for some reason as a super administrator there are some things I can't change (maybe I'm missing something) I may, at a later date take the bit between my teeth, re-instate the core Joomla users and login. Uninstall CB it's modules and dive into the DB and remove all the comprofiler data and start fresh but for now it's working for me, sort of.

Maybe this little snippet might save new users - who may have had a version of CB at an ealier date - a great deal of angst.
Before installing CB go to your database tables and delete all that relate to <prefix>_comprofiler (remembering to back up first) This should make sure that at least there are no built in conflicts from older versions of CB

Would the CB team like to verify my assumptions that this is possibly the reason for this issue?

Post edited by: krileon, at: 2010/08/05 21:51
9 years 3 months ago #139468 by krileon

Would the CB team like to verify my assumptions that this is possibly the reason for this issue?

CB has never created those fields, it has always used them from the CMS.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Templates - CBSubs - Hosting - Forge - Incubator - GroupJive
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM EST to 4:00 PM EST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.
9 years 3 months ago #139501 by Word Warrior
krileon wrote:

CB has never created those fields, it has always used them from the CMS.


Understood but a little confused. If CB uses them from the original CMS and I've just deleted them..... er .... how's it working?

(Although there are some other issues which I'm working on to resolve)

It's still not 100%, (I'll list problems in another thread) but it is working quite well with Kenuna and UddeIM but there are some Super administrator editing issues, i.e. I can't change some things because it says "set in Configuation, can't be changed here" or words to that effect but I can't figure out how to get at them.
:huh:

Thanks in anticipation of any more help.
8 years 11 months ago #147193 by Word Warrior
Just tried to upgrade to 1.3 but get the same error as when I installed 1.2.3 have checked the tables and the rogue ones aren't there so what is causing this this time?

I really do get frustrated with CB, just about everything else I have installed on my site works "right out of the box" but not so CB there is always something you have to tweak.

Have restored my site from backup so the new version does not exist anymore but I was getting a failed to install second stage warning.

Why doesn't it just work!!!!!!:angry:

Hang on, I think I've just managed to post this in the wrong thread:blush: Can a moderator please move it.

Post edited by: Word Warrior, at: 2010/11/29 18:53
Moderators: beatnantkrileon
Time to create page: 0.591 seconds
Facebook Twitter Google LinkedIn