[#4911] CB Connect Google and Facebook login problems

6 years 9 months ago #262545 by waynesj
Hi

This might help, From my mobile device I get the following error:
Authentication Failed. Facebook returned an invalid User ID.

Where can I look to resolve this

Please Log in to join the conversation.

6 years 9 months ago #262564 by krileon
The invalid user id was fixed in CB Connect 6.0.4 it's due to a cURL cert error. Aside from that check your Facebook application settings and ensure it's actually setup for Website usage and you've activated it under Status & Review as by default an application is disabled.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in to join the conversation.

6 years 9 months ago #262565 by waynesj
Hi
The App is definitely setup for Web, I have double checked. While waiting for a response, I have been playing around and I have progressed to the following error.

Failed to retrieve Facebook profile. Error: User profile request failed! Facebook returned an error: CurlException: 6: name lookup timed out

Hope you can help with this

Please Log in to join the conversation.

6 years 9 months ago #262566 by waynesj
Update

Nope, when it dos not time out, I get the Authentication failed, facebook returned an invalid user ID.

Would you be able to look at the setup of my App and in my backend to check I have veryting correct if I provide relevant credentials?

Please Log in to join the conversation.

6 years 9 months ago - 6 years 9 months ago #262572 by krileon
I've upgraded CB Connects version of HybridAuth to latest 2.x release and found a few connection issues and fixed them. We'll have 6.0.5 out sometime today to address connection issues. I've also put in a new try/catch where you issue is occurring so CB Connect can output what's wrong.

With 6.0.5 I have retested all of the connection sites with new applications created so they're all on migrated API. They are all tested working and are all pulling avatars again. So if anyone is having any further issues once using 6.0.5 it is nearly guaranteed to be server or conflict related.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in to join the conversation.

6 years 9 months ago #262779 by waynesj
Hi
Ok, I have updated to CB Connect 6.05.
I have checked every setting in the Facebook App. Screenshots for verification.

I still get this error
Authentication failed! Facebook returned an invalid user id.

When I try Linked in, I get the following error:
Forbidden

You don't have permission to access /components/com_comprofiler/plugin/user/plug_cbconnect/endpoint.php on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

For Google
I get: "Sign up with Google is not permitted."

Twitter
I get: Sign up with Twitter is not permitted.

I am beginning to suspect a permissions problem. All our members are categorised as 'registered in Joomla, or could it be a certificate issue.?

I look forward to your response.

Please Log in to join the conversation.

Moderators: beatnantkrileon
Time to create page: 0.203 seconds

Facebook Twitter LinkedIn