[SOLVED] [#5416] [#5225] Cron job help

6 years 8 months ago - 6 years 8 months ago #261505 by krileon
Replied by krileon on topic Help with cron and mailer
Likely a timing configuration issue on the mailer. Please PM backend super administrator login credentials and will take a look.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in to join the conversation.

6 years 8 months ago - 6 years 8 months ago #261616 by ecweb
Replied by ecweb on topic Help with cron and mailer
Ok - I have pm'd you the details.
One more note - the mailer we are wishing to send is called '2 weeks before expiry'.

Please Log in to join the conversation.

6 years 8 months ago - 6 years 8 months ago #261694 by krileon
Replied by krileon on topic Help with cron and mailer
Your sent mailer log shows several users have received the email on the 23rd and 25th. What has changed since then? I don't see anything particularly wrong with your mailer configuration other than "But do not send message if it's later than:" is set to "1 day" so once you're outside of that 24hr window it won't send the mailer to that user anymore, which means you need to be running the CRON probably multiple times a day. You may want to consider increasing that to 3 days at the least to give more time for the CRON to process everyone.

You also appear to still be on CB 1.x and CBSubs 3.x. A lot has changed sense then so it's possible the issues you're having have already been resolved.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in to join the conversation.

6 years 8 months ago - 6 years 8 months ago #261718 by ecweb
Replied by ecweb on topic Help with cron and mailer
Thanks Kyle for checking it for me.
I have now increased the 'do not send messages later than' to 3 days - but yet it refuses to send any emails.
Earlier I setup a couple of test users and imported them manually one by one - and at that stage the mailer worked fine.
There have been a few minor changes since then - but none that I think should legitimately affect the mailer.

I need to get this email out to subscribers asap as they have their subscriptions expirying now - what do I do to get the mailer in CB working as this is an essential feature for us?
I don't want to upgrade now in the short term as it would take time to get it right and the subscriptions would all expire in the mean time...

Edit ---
I have now done the upgrade as I need to get this moving.
However, the mailers remain in the same situation - not working.

Please Log in to join the conversation.

6 years 8 months ago #261750 by krileon
Replied by krileon on topic Help with cron and mailer
None of your mailers meet the conditions of your users subscriptions. Some also can't logically happen. I've reviewed them all and my comments regarding their configuration as follows.

Post Expiry Email
This mailer is configured to send 2 weeks after the expiration date, but it's checking that the status of the subscription is Active. After the expiration date means it's Expired. So this mailer is in an impossible state. You need to change "Must be in state" to "Expired", but honestly it can be set to "Not relevant" as you're already conditioning on the expiration date so the status doesn't matter (it'll be expired).

2 Weeks before Expiry
This one appears to be configured correctly, but I see no subscriptions that match its requirement. It's only going to send 2 weeks before a user expires and only up to 3 days later. So 2 weeks + 3 days is the window that it'll send. Once out of that window it will no longer attempt to send.

Expiry Email
This one is configured to 12 hours after the expiration date, but it's checking that the status of the subscription is Active. This is the same problem that "Post Expiry Email" has. You need to adjust "Must be in state".

1 Month Before Expiry
This one also appears to be configured correctly, but I don't see any subscriptions that match its requirements.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.
The following user(s) said Thank You: nant

Please Log in to join the conversation.

6 years 8 months ago #261771 by ecweb
Replied by ecweb on topic Help with cron and mailer
Thanks so much Kyle - I do find the settings confusing, and it is useful that you have shed light on these settings.
However having corrected the settings for '2 Weeks before Expiry' and 'Expiry Email' as suggested, no emails are being sent or added to the queue.
For some strange reason the subscriptions are all listed as 'active' (except for 2 test subscriptions) - despite the fact that they expired yesterday. Why would this be?
I have therefore set the mailers for '2 Weeks before Expiry' and 'Expiry Email' to mail users in any 'state' - but they are still not operating.

Please Log in to join the conversation.

Moderators: beatnantkrileon
Time to create page: 0.213 seconds

Facebook Twitter LinkedIn