Manually approving payments not working - Paypal notifications issue

6 years 9 months ago - 6 years 9 months ago #262246 by krileon
Configuration looks fine. It's possible the gateway in CBSubs isn't configured properly (e.g. Business Email could be mismatching the IPN). As I've your credentials for another issue will take a look at your notifications to see if they're not coming through.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in to join the conversation.

6 years 9 months ago #262247 by krileon
Have reviewed your install and you're not receiving IPNs at all. Only PDT (return to site). As your configuration at PayPal looked fine I'm unsure why PayPal is not sending you notifications. I recommend checking the Notifications History in your PayPal account to see if PayPal is even attempting to send IPNs and if they are see what response they're receiving.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in to join the conversation.

6 years 9 months ago #262259 by ecweb
Thanks Kyle,
Paypal is sending the notifications - their Notifications history has listed the IPNs in the status 'retrying'.

Please Log in to join the conversation.

6 years 9 months ago #262296 by krileon
That means the IPN is not reaching your site. Check what URL they're trying to send the IPN to and see what status code the IPN received. You should be able to see these details when clicking to inspect the IPN attempt.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in to join the conversation.

6 years 9 months ago - 6 years 9 months ago #262366 by ecweb
Hi Kyle,
The payment status is 'completed' - but the IPN status is 'retrying'.
We got an email from Paypal about it listing all the failed transactions:
"
Please check your server that handles PayPal Instant Payment Notifications (IPN). Instant Payment Notifications sent to the following URL(s) are failing:

http:/www.mbwc.org.au/index.php?option=com_comprofiler&view=pluginclass&plugin=cbpaidsubscriptions&cbpgacctno=1&cbppdtback=53adf8fa0dd8981b278b2193eca845ea&cbpbasket=34&result=notify&cbpid=cbp5525df16ec776070385255&format=raw"

The host pointed out that if one accesses that url one gets the message 'invalid' displayed on the screen. The same goes for any of the other ipn notification urls.

Please Log in to join the conversation.

6 years 9 months ago #262367 by ecweb
Ok - I've got it working in the oddest possible fashion.
I've installed the old paypal pro plugin for version 3.0 and set it up and modified the notification url accordingly.
If a user then makes a payment via paypal (standard) it works - whereas an error comes up if they try to use paypal pro. I have therefore hidden the paypal pro buttons - and am using paypal standard button with the notification url for paypal pro - and it works!
Strange but good....

Please Log in to join the conversation.

Moderators: beatnantkrileon
Time to create page: 0.179 seconds

Facebook Twitter LinkedIn