[#3630] Renewal Year = Last Year

4 years 10 months ago #219996 by mohsho

krileon wrote: I believe this is due to timezone offset being applied (known issue). Set the site global timezone and the users timezone (if you allow them to change from default) to UTC and confirm if it then displays fine.

I don't know how to set the users' timezones to UTC? Do I just leave it as "Use Default"? And how do I do this for all users?
4 years 10 months ago #220052 by krileon
Leaving it as Use Default then setting global timezone to UTC (first value in timezone dropdown) will force the user and site to use UTC.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Templates - CBSubs - Hosting - Forge - Incubator - GroupJive
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM EST to 4:00 PM EST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.
4 years 10 months ago - 4 years 10 months ago #220053 by mohsho
Ok, so that's what I had done anyway, but I'm still left with the same problem?



And trying to get this live by the end of the day today...
Attachments:
4 years 10 months ago #220056 by krileon
Another user experienced the same issue, but it was renewing for 2013 regardless of it saying 2012. Please try renewing and see if it renews for the proper year. If it does you'll be able to modify the language string and force the year or remove the year for the time being.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Templates - CBSubs - Hosting - Forge - Incubator - GroupJive
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM EST to 4:00 PM EST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.
4 years 10 months ago #220080 by mohsho
Figured it out. I had inserted expiry dates as part of my import and I had used 00:00:00 as the time. The system wants to see 23:59:59.
The following user(s) said Thank You: nant, krileon
3 years 5 months ago - 3 years 5 months ago #246081 by Godzilla Blitz
Me again. I posted the initial question a year or so ago.

As part of a major site overhaul for a client, we've upgraded and renewed everything. My client noticed, however, that this is still an issue with our renewals: they say the year of expiration but renew for the current year.

I've tried...

1. Users are at "use default" for timezone, and the site is at UTC: didn't solve the problem.

2. Expiration times are 23:59:59: still have the same problem.

I'm wondering, could you post directions on how to modify the correct language string to say something like "Renew for the current year"?

I'm rudimentary with php/css, so details would be greatly appreciated.

Thanks in advance!

UPDATE: Humm.... I've installed the language files for English, and have found the word "Reactivate" in language.php, but it just lists the word. I don't see where this is combined to make the appropriate string.

How would I change this: "Reactivate: Year (expired) for (price)" to --> "Reactivate for this year for (price)"
Moderators: beatnantkrileon
Time to create page: 0.272 seconds
Facebook Twitter Google LinkedIn