I Messed up on upgrade to 1.0.1- Any hope?

17 years 3 months ago #19183 by ikt
I'm the dumbo here on this one. I went and backed up my com_comprofiler and then the ue_config.php file in administrator. I did not before hand request for my permissions to be changed before uninstalling, I got confused in some of the directions and ended up missing that part. I must admit, my configuration.php was chmod to 644 and I didn't realize this until after I went in and uninstalled the Community Builder component, so I don't know if this could be the problem?

Anyhow, the administrator com_comprofiler went away, but I'm still seeing the main component com_comprofiler through my ftp, so it is still present, I'm guessing that it shouldn't be? I don't know.

When I go to install the update comprofiler.zip as a component per the directions, I am getting the following:
Upload component-Failed
Another component is already using directory(path to the component).

I guess what I wanted to ask, can I go in and manually remove the old files? And if this is possible, can you tell me what it is that I need to take out before proceeding?
If I have my host change the permissions on that file (that is, if the problem wasn't the fact that my configuration file was set at 644), is there still a possibility of this working from the step I'm at?

When I backed this site up, I did a full backup of my server accounts, and if I don't have to restore everything, that would be the ideal, if there is a way to get around my stump here.

I appreciate your time and support with this.

~Colleen

Post edited by: ikt, at: 2006/08/20 06:18

Please Log in to join the conversation.

17 years 3 months ago #19200 by ikt
I guess maybe the question I should ask is, if I just leave the plugins folder, and delete the rest would this take care of the uninstallation of the previous version?

Or... what files should remain in the com_comprofiler file before installing the new version?

Any help is mucho appreciated!

P.S.- regardless of how this goes, thank you for keeping up on this kind of stuff and your "super keen" way of announcing the updates through the builder itself! I would not have known there were any problems without the red appearance of the warning in my admin area- I saw it right away and it prompted me to begin this fix up.

Please Log in to join the conversation.

17 years 3 months ago #19205 by nant
you need to remove the entire folder (and contents) comprofiler in the components folder and in the administrator/components folder.

then try and install.

Please Log in to join the conversation.

17 years 3 months ago #19206 by nant
ikt wrote:

P.S.- regardless of how this goes, thank you for keeping up on this kind of stuff and your "super keen" way of announcing the updates through the builder itself! I would not have known there were any problems without the red appearance of the warning in my admin area- I saw it right away and it prompted me to begin this fix up.


Glad this is appreciated!

Please Log in to join the conversation.

17 years 3 months ago #19211 by ikt

you need to remove the entire folder (and contents) comprofiler in the components folder and in the administrator/components folder.


Hi Nick,
I noticed, however, that in the upgrade it states not to uninstall the plug-ins, and I guess my next question is, if I remove this folder, will I be losing user data/profiles, or anything that I currently have running through CB before I started the upgrade?

One other question that I have, I also have another site that I am about to add CB to, it is a site in build mode and has no users, or previous data. Is the package 1.0.1 a full package, and if implementing CB to my site, would I simply install that alone as I would any other CB version?

Thanks so much for your help!

~Colleen

Post edited by: ikt, at: 2006/08/20 19:54

Please Log in to join the conversation.

17 years 3 months ago #19215 by nant
ok - you have 2 alternatives.

#1

Mark-down any extra plugins you have installed - keep the zip files handy to reinstall. Cleanout the 2 foldes I mentioned. Install CB 1.0.1 and then reinstall whatever extra plugins you had. Most plugins do not create extra data - the 2 that do (CB Gallery and profile book) will pick up the table data just fine.

#2

Use FTP to over-write all files currently located in the two folders I mentioned with existing files from CB 1.0.1. You should be able to figure out things from the filenames.

Please Log in to join the conversation.

Moderators: beatnantkrileon
Time to create page: 0.225 seconds

Facebook Twitter LinkedIn