Fatal error: allowed memory size exhausted

13 years 9 months ago #34884 by chelby
Hi,

I was getting blank page errors everywhere for CB, every page. I turned on debugging and these were the errors I was getting, instead of the blank page.

[code:1]Fatal error: Allowed memory size of 8388608 bytes exhausted (tried to allocate 58368 bytes) in /home/ashelby20/public_html/components/com_comprofiler/plugin/language/default_language/default_language.php on line 109[/code:1]

And:

[code:1]Fatal error: Allowed memory size of 8388608 bytes exhausted (tried to allocate 14592 bytes) in /home/ashelby20/public_html/modules/mod_jflanguageselection.php on line 156[/code:1]

Every page that was blank, is saying pretty much this same thing about the memory error??

I am running PHP 5 on a virtual dedicate server through godaddy and have root access to everything if I need it.

I finally got this working by changing the memory limit fix that has been reported.

BUT, I HAD TO RESTART THE APACHE SERVER FOR THE NEW SETTINGS TO TAKE EFFECT. I know some people may not be able to do this, but it is what worked for me.

Good luck,

Aric

Please Log in to join the conversation.

13 years 9 months ago #34885 by chelby
Oh, my site is located at:

http://www.shipplotting.com

I must say, I was freaking out for the last hour trying to get this sorted out, thank god for the forum here and all the great posts.

I'm loving Joomla more every day.

Aric

Please Log in to join the conversation.

12 years 3 months ago #77421 by wrsite
I installed community builder 1.1 on my joomla site several months ago and have never had a problem. Yesterday, my users could not login using the login form on the home page. All users, including myself receive the following error:

Fatal error: Allowed memory size of 8388608 bytes exhausted (tried to allocate 184320 bytes) in /homepages/38/d208294027/htdocs/mysite/components/com_comprofiler/plugin/user/plug_cbmenu/cb.menu.php on line 1037

I've read through all posts on memory allocation and have modified my php.ini file as follows:

<?php

ini_set('memory_limit','32M')

register_globals= "Off"

upload_max_filesize = 8M;

memory_limit = 32M ;?>

I may have this file in the wrong directory. Where should it be posted? Is this one of those files I need to post in multiple directories?

I still receive the error and don't understand what others did to resolve the issue. I'm brand new to joomla and php so I don't understand most of the lingo. What should I do to correct this?

by the way, I can login to joomla as an administrator via the administrator URL, but I cannot login through the CB Login form.

Post edited by: wrsite, at: 2008/10/15 18:12

Please Log in to join the conversation.

12 years 3 months ago #77559 by Rapunzl
Replied by Rapunzl on topic Re:Fatal error: allowed memory size exhausted
First, you need to change htaccess.txt to .htaccess. Then you have to enable apache mod_rewrite in your Joomla Global Configuration.

Jamie (Rapunzl)
Community Builder Team Member

Before posting on forums: Read all CB Articles | Specially the FAQ | Help us help you
CB links: Subscribe to CB documentation | [url=http://www.joomlapolis.com/content/view/7363/37/
]Our templates[/url] | [url=http://www.joomlapolis.com/content/blogcategory/61/74/
]Paid Subscriptions[/url] | Get Hosting | Our Forge
Visit my CB Profile

My personal site Rapunzl's Reality always under reconstruction

Please Log in to join the conversation.

12 years 2 months ago #77585 by wrsite
Ok, I tried that with bizarre results.

I renamed my htaccess.txt to .htaccess

After that, I selected Apache mod rewrite, but as soon as I clicked save I received this error.

Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request.

I was able to change .htaccess back to htaccess.txt and restored the site so I could access it again, but neither my users nor I can login from the front-end.

is there something else I'm missing? Do you think my htaccess.txt file could be the wrong one? Where would I get a suitable replacement?

Maybe I should mention my host is 1and1 and I'm using Joomla 1.5.2

Post edited by: wrsite, at: 2008/10/23 13:19

Please Log in to join the conversation.

12 years 2 months ago #78056 by wrsite
I'm checking in to see if anyone has any suggestions for the

"Fatal error: Allowed memory size of 8388608 bytes exhausted (tried to allocate 184320 bytes) in /homepages/38/d208294027/htdocs/mysite/components/com_comprofiler/plugin/user/plug_cbmenu/cb.menu.php on line 1037"

I still receive that error if I try to login to the community builder login form.

I tried the suggestions below but have not corrected the error.

What do you recommend?

My host says I cannot increase the memory limit "Due to resource limits on our Shared Hosting machines, it is not possible to allocate more than 20M
of memory to PHP, although phpinfo() may report a higher number. You will be unable to increase
the memory usage limit with a php.ini file."

I didn't install anything new at the time this error occurred, but I was able to login previously. What would cause this to happen?

Post edited by: wrsite, at: 2008/10/23 13:16

Please Log in to join the conversation.

Moderators: beatnantkrileon
Time to create page: 0.398 seconds

Facebook Twitter LinkedIn