6:Site started before CB 1.0 RC 2, tabs messed

11 years 5 months ago #64712 by beat
This issue is now fixed in Community Builder 1.2 RC 2.
Community Builder 1.2 RC 2 is a recommended upgrade.




With this issue 6, we have finally catched up the discussions forum, and hope to have listed all known issues as of this minute with CB 1.2 RC, 4 days after its release.

With only 6 issues after 4 days RC, I have to say a big THANKS to the CB testteam, for its great testing work.

So here comes issue 6: not completely confirmed, but improvements will be made for next release: just wanted to list it as known issue to have a complete list in here:

If you started your website with Community Builder before CB release 1.0 RC 2 (that's 3 years ago), there is a probability that the database upgrader won't catch the very old database structure well, as some numberings might have changed since first public CB 1.0 beta 4 long ago.

In that case (if you started with CB on a site *before release 1.0.0 RC 2*) it might be safe to wait for next release before upgrading database. Or to install a blank CB 1.2 RC and check your comprofiler_tabs and comprofiler_plugins mysql tables, that the tabid/pluginid and pluginclass match CB 1.1 or CB 1.2 RC fresh installs before upgrading.

In any case always backup database before upgrading, so you can rollback if needed. Very specially in this case.

Symptoms:

- You started on the site with CB before CB 1.0.0 stable

- Tabs look mixed up in user profile after release.

- Fields jumped to other tabs

- some tabs got recreated, showing twice author tab, e.g.

- Don't see those fields in users-list (in addition of the above !)

- Possibly cannot register or save user in frontend

- CB database checker returns that all is fine


Workaround:


Either:
- rollback then fix tabid of comprofiler_tabs table and pluginid of comprofiler_fields table (and all related tabid in comprofiler_fields table manually

- or wait for next release.

We will now prefer fixing this automatic upgrader issue properly within next days, then trying to design SQL queries to get around this manualy.

Related main discussion-thread:

www.joomlapolis.com/component/option,com_joomlaboard/Itemid,38/func,view/catid,50/id,64702/#64702

EDIT: key release is 1.0 RC 2 for this issue and not CB 1.0.0 stable

Post edited by: beat, at: 2008/06/10 15:34

Post edited by: beat, at: 2008/07/01 14:02

Beat - Community Builder Team Member

Before posting on forums: Read FAQ thoroughly -- Help us spend more time coding by helping others in this forum, many thanks :)
CB links: Our membership - CBSubs - Templates - Hosting - Forge - Send me a Private Message (PM) only for private/confidential info
11 years 4 months ago #66960 by beat
This issue is now fixed in Community Builder 1.2 RC 2.

Community Builder 1.2 RC 2 is a recommended upgrade.

Beat - Community Builder Team Member

Before posting on forums: Read FAQ thoroughly -- Help us spend more time coding by helping others in this forum, many thanks :)
CB links: Our membership - CBSubs - Templates - Hosting - Forge - Send me a Private Message (PM) only for private/confidential info
Moderators: beatnantkrileon
Time to create page: 0.433 seconds
Facebook Twitter Google LinkedIn