#142 Session expired... enable cookies.

13 years 7 months ago #82764 by mtk
beat wrote:

mtk,

I'm offering to skittle and you an easy work-around solution UNTIL we fix that bug in CB 1.2 Stable. If you have a simpler or better way to workaround this CB 1.2 RC 4 bug without code edit or a code fix, please propose, we are still in RC :) .

sorry, it sounded like a permanent thing...

beat wrote:

You can put "index.php" into first-page-login-URL in CB config to make it work fine with SEF in CB 1.2 RC 4.

I've set index.php in the config as you suggested.

beat wrote:

Btw joomla and mambo do not redirect users loging-in to homepage, but stays on same page by default, including on first login, if it's not a registration-related page. That's also how CB normally behaves (except this bug).

I've also added the common Joomla Login module.
I've set index.php in the module.


please, feel free to go back into the test site I sent you, and test both cases...

Post edited by: mtk, at: 2008/12/18 15:13

Please Log in to join the conversation.

13 years 7 months ago #82776 by elaperriere
Replied by elaperriere on topic Re: #142 Session expired... enable cookies.
yeah sorry... I am dealing with so many different modules right now!! I meant the register button when I was talking about the ok button.

Please Log in to join the conversation.

13 years 7 months ago #82786 by skittle
Replied by skittle on topic Re:#142 Session expired... enable cookies.
hi Beat,

Thanks for the quick response. Per your suggestions concerning the "first time login welcome page" from page 2, I have set mine to a variety of different articles (using index.php?Itemid=1 and similar variations - obviously replacing the number to reflect the appropriate document). I have also left the first-time field blank just to test. The "welcome" pages will appear as expected per these configuration changes as long as SEF is turned off. As soon as SEF is switched on I get the "session expired..." again when logging in. Am I missing something? :S

Please Log in to join the conversation.

13 years 7 months ago #83208 by beat
Issue is now identified and fixed for shortly upcoming CB 1.2 Stable.

Quick-fix:

search "function login(" in components/com_comprofiler.php

in that function search for:
[code:1] $return = $ueConfig;
[/code:1]

and add an else statement after it, so that the entire portion looks like this:
[code:1] elseif ($row->lastvisitDate == '0000-00-00 00:00:00') {
if (isset($ueConfig) and ($ueConfig != ""«»)) {
$return = $ueConfig;
} else {
$return = null; // by default return to homepage on first login.
}
[/code:1]

in that same function search for a line with 2 times "strncasecmp" in it, and replace that long line simply with:

[code:1] $returnURL = cbSef( $return, false );
[/code:1]

@All in here:
Please confirm that this fix works for you too, before I move that thread to identified issues. Thanks.

EDIT: Logout has a similar bug in it but it's way more minor, and fixed for upcoming Stable. :)

Post edited by: beat, at: 2008/12/23 12:08

Beat - Community Builder Team Member

Before posting on forums: Read FAQ thoroughly -- Help us spend more time coding by helping others in this forum, many thanks :)
CB links: Our membership - CBSubs - Templates - Hosting - Forge - Send me a Private Message (PM) only for private/confidential info

Please Log in to join the conversation.

13 years 7 months ago #83397 by thedroop
Replied by thedroop on topic Re:#142 Session expired... enable cookies.
darn,

I think I am having the same problems

the above fix didn't help :(

It's weird, ive been trying everything for hours -


I will clear the cache & I can register accounts, I tried again 10 mins later then I get this "enable cookies message"

Please Log in to join the conversation.

13 years 7 months ago #83560 by skittle
Replied by skittle on topic Re:#142 Session expired... enable cookies.
Hi beat - unfortunately, the code change to comprofiler.php did not help my installation either. I have cleared all caches, tried with 4 different browsers from different machines. There is no new or different behavior to report. Still the same "session expired..." message. The only, thing that works for me is turning off the Joomla global SEF setting.

Thanks again for your attention.

Please Log in to join the conversation.

Moderators: beatnantkrileon
Time to create page: 0.238 seconds

Facebook Twitter LinkedIn