#141 Registration passwd with auto-password

10 years 10 months ago #83893 by mkampstra
I Confirm this problem.

Disabled password and required in field management.
And let CB make password.

People register, get email, confirm email, i get mail for approval action.

And frontpage (with workflow) i approve it.

User get mail with very long password which wont work.
something like:
03198841e67e21ce257a2e4d73de7f94:blG24HGHEpH2KGCaRRsYJSxgn1Mgvqqe
This looks like the original password field as in the Mysql database jos_users

In backend is see user is enabled but not yet approved.

CB1.2RC4 on J1.5.8 with Dutch language files.

Need more info??

Post edited by: mkampstra, at: 2009/01/02 15:54
10 years 10 months ago #84220 by krileon
Using the combination of settings will cause this undesired effect, because:

Passwords are not stored in plaintext. When you approve a user the "Welcome Email" is sent. In this email you've given the user their password. Problem? The password was not grabbed in plaintext, because it isn't possible without it being typed in plaintext and posted.

So to fix it. Give the user their password in the "Pending Approval Email". Then simply have your welcome email just that; a welcome email. Do NOT include their password in it or it -WILL- be hashed.

Now this is only with this combination of settings, but it's still recommended to give the users password to them ASAP.

Just because they have the password it does NOT mean they can login, because you still need to approve them.

This is a temporary workaround until the bug has been officially fixed!

Post edited by: krileon, at: 2009/01/05 18:50


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Templates - CBSubs - Hosting - Forge - Incubator - GroupJive
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM EST to 4:00 PM EST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.
10 years 10 months ago #84266 by mkampstra
Hi,

Well the funny thing is that the password only is scrambled on approve with the Frontend approval button. When approved in backend.. There is no problem. Why does it work in backend but not as it should be in frontend. My solution is to only approve in backend...

Greetings Merte
10 years 10 months ago #84315 by krileon
mkampstra wrote:

Hi,

Well the funny thing is that the password only is scrambled on approve with the Frontend approval button. When approved in backend.. There is no problem. Why does it work in backend but not as it should be in frontend. My solution is to only approve in backend...

Greetings Merte


Because the backend is separate code from the frontend.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Templates - CBSubs - Hosting - Forge - Incubator - GroupJive
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM EST to 4:00 PM EST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.
10 years 9 months ago #85603 by beat
These bugs are now reproduced and confirmed here.

I just applied a fix proposal received and re-did full test of all the workflows with auto-generate password which are new in CB 1.2 and that showed quite some bugs poping up like reported above, and a few more.

All are now fixed for upcoming CB 1.2 Stable.

Moving to identified issues.

Thanks for your tests and detailed reports, this has been a good bugs-tread B)

Beat - Community Builder Team Member

Before posting on forums: Read FAQ thoroughly -- Help us spend more time coding by helping others in this forum, many thanks :)
CB links: Our membership - CBSubs - Templates - Hosting - Forge - Send me a Private Message (PM) only for private/confidential info
Moderators: beatnantkrileon
Time to create page: 0.423 seconds
Facebook Twitter Google LinkedIn