VALID_AZ09 on profile update page

11 years 2 months ago #138573 by WarrenN
VALID_AZ09 on profile update page was created by WarrenN
I have been trying to save a profile after uploading a logo, the image appears to be uploaded but not saved. I get a dialog box that says "VALID_AZ09".
Trying other names it appears that any name that has an "&" in it does the same thing.
Any help would be appreciated.

Please Log in to join the conversation.

11 years 2 months ago #138685 by krileon
Replied by krileon on topic Re:VALID_AZ09 on profile update page
Please upgrade to CB 1.2.3. The message should be displayed as "Please enter a valid %s. No spaces, more than %d characters and contain 0-9,a-z,A-Z". Special characters, etc.. should never be in filenames and are not supported.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in to join the conversation.

11 years 2 months ago #138758 by infotechdesign.net
Replied by infotechdesign.net on topic Re:VALID_AZ09 on profile update page
I'm on CB 1.2.3 and am getting this on the User Management when I put a first name in. I tried "Sammy" for the first name and the last name and that's the message I get - "VALID_AZ09" not the long description you mentioned.

Any ideas?

Please Log in to join the conversation.

11 years 2 months ago #138776 by krileon
Replied by krileon on topic Re:VALID_AZ09 on profile update page
Sounds like your CB installation is not complete. You're missing language strings. Please re-install CB.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in to join the conversation.

11 years 2 months ago #139360 by infotechdesign.net
Replied by infotechdesign.net on topic Re:VALID_AZ09 on profile update page
Okay, I reinstalled CB and it made no difference.

What I found out was that the Username field had an ampersand (&) in it, and once I removed that, the update to the user went through.

I guess I take issue with two things:

1) The error message is somewhat cryptic - so CB is apparently not using the language strings on this field for the error
2) There is nothing telling you what field it is talking about. I went back and tried it again, and you get the message in a popup, and when you hit OK you go back to the user edit, and there's nothing I could see telling you the field with the problem.

Please Log in to join the conversation.

11 years 2 months ago #139363 by krileon
Replied by krileon on topic Re:VALID_AZ09 on profile update page

1) The error message is somewhat cryptic - so CB is apparently not using the language strings on this field for the error

Not sure why your string is not properly translating. Could be due to a number of issues. Please follow debug procedures within Help Us Help You found in my signature.

2) There is nothing telling you what field it is talking about. I went back and tried it again, and you get the message in a popup, and when you hit OK you go back to the user edit, and there's nothing I could see telling you the field with the problem.

The message isn't translated so of course it isn't telling you what's wrong. When translated it informs you of what the error is. Information icons are also used to provide users with information on a field, perhaps including how the field should be formatted would be a good idea.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in to join the conversation.

Moderators: beatnantkrileon
Time to create page: 0.201 seconds

Facebook Twitter LinkedIn