HUGE ISSUE: Account & Subscription NOT Activated!

12 years 4 months ago #105207 by carlosleon0615
Replied by carlosleon0615 on topic Re:HUGE ISSUE: Account & Subscription NOT Activated!

Do you have e-mail confirmation or moderator approval set for users and have you approved them?

In CB Settings I have:
Require Admin Approval = NO
Require Email Confirmation = NO

Was funds actually draw from the user, how many users is this affecting?

No because all my plans offer FREE trials so funds are not supposed to be withrawn until the trial ends.

Upon further testing, I found out that the problem occurs ONLY for those plans with a Free trial period.
I created a test plan that does Not provide a free trial period and everything works there (account is activated, user receives emails, subscription gets activated).

I then modified the same test plan to have a Free 1-day trial period. This is when the problem occurs. The thank you notes on the site are displayed but the account is not activated, no emails are sent and the subscription remains inactive asking the user to PAY when trying to login.

So, it seems that the account and subscription get activated only when Paypal withdraws money and Not during trial periods. I doubt this is a Paypal problem because this used to work in CBSubs 1.0.1 (as you might realize, I've been constantly testing it).

I hope this gives you more insight on where the issue can be. Offering Free trials is a Must for us. I really need a solution as I was supposed to make my site "live" last week but was waiting for the bug fixes in CBSubs 1.0.2. I can't really wait that long anymore :(

Thanks for all your help!

Carlos

Post edited by: carlosleon0615, at: 2009/07/17 02:54

Please Log in to join the conversation.

12 years 4 months ago #105250 by krileon
On attempt to duplicate your issue. I've found that paypal does not and will not accept payments of $0.

A user needs to click the Free Trial button when going to pay in order to take advantage of the free trial.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in to join the conversation.

12 years 4 months ago #105255 by carlosleon0615
Replied by carlosleon0615 on topic Re:HUGE ISSUE: Account & Subscription NOT Activated!

I've found that paypal does not and will not accept payments of $0.

That is Only true for 1-time payments.

For auto-recurring Subscriptions, Paypal has the ability to offer a FREE ($0.00) trial period and then automatically charge. This is part of the regular Paypal subscription configuration.

As I've been saying, this had been working since CBSubs 1.0!

How can I help you reproduce the problem?
It's simple. Create an auto-recurring plan that gives a free-trial period. Subscribe to it and you'll see that Paypal correctly accepts the terms (Free Trial for X days, then $y.yy each ZZ). When you click on pay, Paypal correctly tells you that "Your FIRST payment of $0.00 has successfully posted. You'll now be redirected to XXX company [the original site where they subscribed]."

You or one of the developers could try the same in CBSubs 1.0.1 and see if you get different results (which I bet you will, it will work there). This way, that might help the developers realize this is a REAL Big issue and hopefully this can get bumped up in Priority.

I'm persistant on this because this one feature (Using Paypal to offer free trials and then automatically charge on specified periods) was the reason why I purchased CBSubs switching from JoomSuiteMember. And was happy to see it working flawlessly at the beginning.

Please don't drop the ball on this.

Thanks for your efforts,

Carlos

Post edited by: carlosleon0615, at: 2009/07/17 15:45

Please Log in to join the conversation.

12 years 4 months ago #105269 by krileon
Will require further investigation. No ETA on fix as if there is a problem a fix will be in place for next maintenance release.

#1167

Post edited by: krileon, at: 2009/07/17 16:37


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in to join the conversation.

12 years 4 months ago #105270 by carlosleon0615
Replied by carlosleon0615 on topic Re:HUGE ISSUE: Account & Subscription NOT Activated!
I guess I'll have to revert back to CBSubs 1.0.1 :(

Is there any special instructions on how to do that? Or should I just uninstall all plugins, module and main component, then reinstall their 1.0.1 version?

Will the settings and plans remain intact or will they be lost?

Thanks,

Carlos

Please Log in to join the conversation.

12 years 4 months ago #105272 by krileon
It's advised not to revert to an older version, but simply replace all the files in the same manor you upgraded to 1.0.2.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in to join the conversation.

Moderators: beatnantkrileon
Time to create page: 0.191 seconds

Facebook Twitter LinkedIn