[ITEM_ALIAS] doesn't work! Replaced with Blank

12 years 4 months ago #105181 by krileon
  1. It does.
  2. It does work, if multiple purchases are made in 1 payment basket.

Again, please re-read what I wrote:

The following controls Paypals display:
Global Settings -> Display -> Baskets -> Payment basket item text


Payment item text and Payment processor item text (short) do not affect Paypal.

Or can we then openly state that we can send the Alias to other payment gateways EXCEPT for Paypal?

Yes, everyone must keep in mind there are multiple gateways supported. Not every setting will affect all of them due to limitation of gateway.

Post edited by: krileon, at: 2009/07/16 21:26


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in to join the conversation.

12 years 4 months ago #105200 by carlosleon0615
Replied by carlosleon0615 on topic Re:[ITEM_ALIAS] doesn't work! Replaced with Blank
krileon wrote:

  1. It does.

If it is supposed to work, I might be missing something. These are my plans settings:
Alias (short-name) of plan = My Alias
Payment item text = [ITEM_ALIAS]

And that results in the invoice having an EMPTY item. Please see screenshot.

Am I doing something wrong?

Or can we then openly state that we can send the Alias to other payment gateways EXCEPT for Paypal?

Yes, everyone must keep in mind there are multiple gateways supported. Not every setting will affect all of them due to limitation of gateway.

I'm glad at least now I now the "Alias (short-name)" has never been supported to send to Paypal. I hope you support it at some point as there's no way to use the workaround you gave me for the invoice (see my P.S. below).

Thanks,

Carlos
P.S. The workaround works great for the invoice. This is, I set the following:
Payment item text = PlanA_PaymentItemText

I then defined "PlanA_PaymentItemText" in my English and Spanish language files to whatever name I wanted to display and that works!

Post edited by: carlosleon0615, at: 2009/07/17 01:06
Attachments:

Please Log in to join the conversation.

12 years 4 months ago #105251 by krileon
Again, I do not believe [ITEM_ALIAS] is meant to work in the text (non-short). This is to prevent providing too little information to users when checking invoices and such (please keep in mind this is dealing with users money regulations in various countries must be met). The alias is only used when it's absolutely necessary to keep the name short. If you want different names, etc.. for the title then simply type in that title or add it to the language file as a string as you've done.

I can neither confirm or deny if this is a bug or not unfortunately. It will require delving into the code. At any rate if it is a bug it will be fixed for next maintenance release.

#1166

Post edited by: krileon, at: 2009/07/17 15:29


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in to join the conversation.

12 years 4 months ago #105262 by carlosleon0615
Replied by carlosleon0615 on topic Re:[ITEM_ALIAS] doesn't work! Replaced with Blank
krileon wrote:

At any rate if it is a bug it will be fixed for next maintenance release.

Good enough especially since the workaround works great. Thanks!

Please Log in to join the conversation.

Moderators: beatnantkrileon
Time to create page: 0.168 seconds

Facebook Twitter LinkedIn