"Restricted access" error in CB Paid Subscriptions

14 years 5 months ago #116911 by webwichtl
Hi there,

I just installed CB Subs on my Joomla 1.5 site, but I can't access the CB Paid Subscriptions plugin. When I click on "CB Paid Subscriptions" in the CB Plugin Manager, I get an empty page saying "Restricted access".

What shall I do?

Please Log in to join the conversation.

14 years 5 months ago #116918 by krileon
Did you check your CBSubs manual to ensure your host meets CBSubs requirements? Is the user you're logged in as a Super Administrator? Any errors in server error log? Need more information.. please review Help Us Help You in my signature.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in to join the conversation.

14 years 5 months ago #116951 by webwichtl
I've double-checked all installation steps and found out that it works only when system legacy plugin is ENABLED. Disabling legacy mode makes CB Paid Subscriptions plugin inaccessible again (and vice versa).
If I need to have legacy mode OFF, what am I supposed to do?

Please Log in to join the conversation.

14 years 5 months ago #116964 by krileon
Replied by krileon on topic Re:
webwichtl wrote:

I've double-checked all installation steps and found out that it works only when system legacy plugin is ENABLED. Disabling legacy mode makes CB Paid Subscriptions plugin inaccessible again (and vice versa).
If I need to have legacy mode OFF, what am I supposed to do?


CBSubs works native, but CBSubs does load all your CB plugins to find integrations. What this means is you have a plugin installed that requires legacy mode, but that plugin is not CBSubs as confirmed and tested native. Please check your installed plugins and find the culprit; generally these are 3rd party plugins.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in to join the conversation.

14 years 5 months ago #116991 by webwichtl
Replied by webwichtl on topic Re:
Indeed, there is Auction Factory installed, which requires legacy mode. But it has been disabled and legacy isn't required any more. Do I have to completely remove Auction Factory? And when I've done so, do I have to reinstall CBSubs, or will it automatically recognize that it can work in native mode now?

Please Log in to join the conversation.

14 years 5 months ago #116994 by krileon
Replied by krileon on topic Re:
webwichtl wrote:

Indeed, there is Auction Factory installed, which requires legacy mode. But it has been disabled and legacy isn't required any more. Do I have to completely remove Auction Factory? And when I've done so, do I have to reinstall CBSubs, or will it automatically recognize that it can work in native mode now?


CBSubs loads all plugins in an attempt to find integration plugins; in other words yes you need to uninstall it if you're not using it otherwise enable legacy mode. Uninstalling it will instantly remove the error as the legacy dependent plugin will no longer be present.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in to join the conversation.

Moderators: beatnantkrileon
Time to create page: 0.393 seconds

Facebook Twitter LinkedIn