[SOLVED] Installation com_comprofiler

10 years 10 months ago #147954 by jdcrooner
Replied by jdcrooner on topic Re:Installation com_comprofiler
tvegas wrote:

Parse error: syntax error, unexpected T_STATIC, expecting T_OLD_FUNCTION or T_FUNCTION or T_VAR or '}' in /home/XXXXXXXXX/public_html/administrator/components/com_comprofiler/plugin.foundation.php on line 894

Receive the above message when attempting to install.
(XXXXXXXXX - I replaced directory name)


??

I got the same error message when I went to install and
I got the same error message when I went to enable cb login. didn't even get past that.

php local host server version is 5.0.37
php myadmin 2.11.7
So what needs upgrading???

jdcrooner

Please Log in to join the conversation.

10 years 10 months ago #147963 by beat
Replied by beat on topic Re:Installation com_comprofiler
jdcrooner wrote:

php local host server version is 5.0.37
php myadmin 2.11.7
So what needs upgrading???


5.0.37 looks like a Mysql version, as PHP 5.0.37 never existed. ;)

The error you are getting is really that it's PHP 4.

Beat - Community Builder Team Member

Before posting on forums: Read FAQ thoroughly -- Help us spend more time coding by helping others in this forum, many thanks :)
CB links: Our membership - CBSubs - Templates - Hosting - Forge - Send me a Private Message (PM) only for private/confidential info

Please Log in to join the conversation.

10 years 10 months ago #148012 by getrowdy
Replied by getrowdy on topic Re:Installation com_comprofiler
Searching the forum before posting just with "line 894" would have lead you as very first result to this thread and to the reply and fact that you do not have the prerequired PHP 5 installed:

www.joomlapolis.com/component/option,com_joomlaboard/Itemid,/func,view/catid,143/id,147954/#147954

Most hosts have a switch where you can swap it up to PHP 5. Worst case senario find a new host. Possibly use the hosting provided here at CB if your host gives you issues.

Post edited by: getrowdy, at: 2010/12/07 20:13

Please Log in to join the conversation.

10 years 10 months ago #148333 by beat
Replied by beat on topic Re:Installation com_comprofiler
Following the initial feedback in this thread, we have already added an additional PHP version check at very begin of installer, so that others with 2+ -years obsolete unsecure hosts get an even clearer error message.

This check is included in released CB 1.3.1, and at very begin of installer (installer being maintained PHP 4 compatible for that sole purpose).

Beat - Community Builder Team Member

Before posting on forums: Read FAQ thoroughly -- Help us spend more time coding by helping others in this forum, many thanks :)
CB links: Our membership - CBSubs - Templates - Hosting - Forge - Send me a Private Message (PM) only for private/confidential info

Please Log in to join the conversation.

Moderators: beatnantkrileon
Time to create page: 0.169 seconds

Facebook Twitter LinkedIn