registration session expired and/or cookies are no

14 years 5 months ago #39995 by nimakhaj
I tried all posted suggestions and solutions and none of them worked. I even commented the spam checking and changed === to ==, but now after submitting response freezes and does not return back anything until php returns timeout. How can I download the previous version of CB? It used to work fine with older vrsion.

Please Log in to join the conversation.

14 years 5 months ago #40206 by prog_web
I try everything who said in this topic but nothing works. My registration is not working. When try to register, and click the button to submit the registration, open a alert who say "Session expired". I have the following server:

PHP built On: Linux web22.f3.k8.com.br 2.6.17-13mdventerprise #1 SMP Fri Mar 23 19:07:16 UTC 2007 i686
Database Version: 4.0.20'-Max'-log
PHP Version: 5.2.1
Web Server: Apache
WebServer to PHP interface: apache2handler
Joomla! Version: Joomla! 1.0.12 Stable [ Sunfire ] 25 December 2006 01:00 UTC
User Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; pt-BR; Alexa; rv:1.8.1) Gecko/20061010 Firefox/2.0

Please Log in to join the conversation.

14 years 5 months ago #40234 by SuperGuido
I posted a 'fix' which is really just doing some minor surgery on the code :)
It's in another thread
Here

Generation: Gamerz
www.generationgamerz.com
News. Reviews. Culture. Insight.
By Gamerz. For Gamerz.

Please Log in to join the conversation.

13 years 1 month ago #77824 by DavidAndrew
Here is some discussion from me and one of my developer, he eventually fixed the issue

The error is only shown when the Community Builder cookie is not saved correctly on the user computer. On most computers this goes perfectly so we dont get the error.

So we need to know why some computers dont save the cookie. Community Builder also talks about his here:

www.joomlapolis.com/component/option,com_joomlaboard/Itemid,38/func,view/catid,27/id,40108/

www.joomlapolis.com/component/option,com_joomlaboard/Itemid,38/func,view/id,36419/catid,29/limit,6/limitstart,0/

To get the error:
- go to the domeinname with FF3
- go to "Firefox > Preferences > Privacy > Show cookies"
- search for domeinname
- find cbrvs cookie and delete it
- close preferences

- on domeinname (already opened, DONT REFRESH)
- click sign up and sign up
- after you click register you should get the error

SOLUTION
I have tried to fix this issue in various ways.
1.By the intruction forum, i have tried but it was not helpful.

2.After that i have installed the same version of CB1.1 in my local machine. It comes the same error.

And also I have upgraded the latest version and tested. But it was also comes the same error.

3.After that i have gone through the source code to find the flow. Finally i have commented the one condition in the folowing file.
comprofiler.class.php
line no: 2489

After commenting this line , its work fine.

Please Log in to join the conversation.

13 years 1 month ago #77853 by beat
This registration issue has been finally solved in CB 1.2 RC 3. It was due to sites with www and non-www variants both being served.

Note: for login that remains an issue, due to the way that joomla handles cookies. We are looking into a way to get around that last issue in next build.

Beat - Community Builder Team Member

Before posting on forums: Read FAQ thoroughly -- Help us spend more time coding by helping others in this forum, many thanks :)
CB links: Our membership - CBSubs - Templates - Hosting - Forge - Send me a Private Message (PM) only for private/confidential info

Please Log in to join the conversation.

13 years 1 week ago #80461 by patpat
Hi Beat,

i have the same problem since RC3(i didn't experience it before :dry: ).

The "registration session expired and/or cookies are ..." message appears in red just when the username verification is in progress.

Cheers

Nothing's left for invention.
Keep your ears and eyes wide open !

Please Log in to join the conversation.

Moderators: beatnantkrileon
Time to create page: 0.285 seconds

Facebook Twitter LinkedIn