[Mambo 4.6.2 bug]: Error On Clean Install

13 years 10 months ago #42367 by jplagarde
I unstalled mambo and reinstalled it, starting clean, tried to install 1.1 and got the following error on installing the first part (comprofiler.zip). Any advice would be greatly appreciated!!!!!


Copyright 2004 - 2007 MamboJoe/JoomlaJoe, Beat and CB team on joomlapolis.com . This component is released under the GNU/GPL version 2 License and parts under Community Builder Free License. All copyright statements must be kept. Derivate work must prominently duly acknowledge original work and include visible online links. Official site: www.joomlapolis.com

Installation Process:
Start correcting icons in administration backend.
FINISHED: Image of menu entry 0 has been corrected.
FINISHED: Image of menu entry 1 has been corrected.
FINISHED: Image of menu entry 2 has been corrected.
FINISHED: Image of menu entry 3 has been corrected.
FINISHED: Image of menu entry 4 has been corrected.
FINISHED: Image of menu entry 5 has been corrected.
1.0 Beta 4 to 1.0 RC 1 Upgrade Applied Successfully!
1.0 RC 1 to 1.0 RC 2 part 1 Upgrade Applied Successfully!
1.0 RC 1 to 1.0 RC 2 part 2 Upgrade Applied Successfully!
1.0 RC 1 to 1.0 RC 2 part 3 failed! SQL error:DB function failed with error number 1146
Table 'jplagard_mamb1.mos_comprofiler_members' doesn't exist SQL=ALTER TABLE `mos_comprofiler_members` ADD `reason` MEDIUMTEXT default NULL AFTER `membersince`
SQL =
ALTER TABLE `mos_comprofiler_members` ADD `reason` MEDIUMTEXT default NULL AFTER `membersince`

1.0 RC 1 to 1.0 RC 2 part 3 Upgrade Applied Successfully!
1.0 RC 2, 1.0 and 1.0.1 to 1.0.2 failed! SQL error:DB function failed with error number 1146
Table 'jplagard_mamb1.mos_comprofiler_members' doesn't exist SQL=ALTER TABLE `mos_comprofiler_members` ADD INDEX `pamr` ( `pending` , `accepted` , `memberid` , `referenceid` );
SQL =
ALTER TABLE `mos_comprofiler_members` ADD INDEX `pamr` ( `pending` , `accepted` , `memberid` , `referenceid` );

1.0 RC 2, 1.0 and 1.0.1 to 1.0.2 failed! SQL error:DB function failed with error number 1146
Table 'jplagard_mamb1.mos_comprofiler_members' doesn't exist SQL=ALTER TABLE `mos_comprofiler_members` ADD INDEX `aprm` ( `accepted` , `pending` , `referenceid` , `memberid` );
SQL =
ALTER TABLE `mos_comprofiler_members` ADD INDEX `aprm` ( `accepted` , `pending` , `referenceid` , `memberid` );

1.0 RC 2, 1.0 and 1.0.1 to 1.0.2 failed! SQL error:DB function failed with error number 1146
Table 'jplagard_mamb1.mos_comprofiler_members' doesn't exist SQL=ALTER TABLE `mos_comprofiler_members` ADD INDEX `membrefid` ( `memberid` , `referenceid` );
SQL =
ALTER TABLE `mos_comprofiler_members` ADD INDEX `membrefid` ( `memberid` , `referenceid` );

1.0 RC 2, 1.0 and 1.0.1 to 1.0.2 Upgrade Applied Successfully!
1.0.2 to 1.1 Upgrade Applied Successfully!

/home/jplagard/public_html/avemux//images/comprofiler/ Successfully added!
/home/jplagard/public_html/avemux//images/comprofiler/gallery/ Successfully added!
airplane.gif Successfully added to the gallery!
ball.gif Successfully added to the gallery!
butterfly.gif Successfully added to the gallery!
car.gif Successfully added to the gallery!
dog.gif Successfully added to the gallery!
duck.gif Successfully added to the gallery!
fish.gif Successfully added to the gallery!
frog.gif Successfully added to the gallery!
guitar.gif Successfully added to the gallery!
kick.gif Successfully added to the gallery!
pinkflower.gif Successfully added to the gallery!
redflower.gif Successfully added to the gallery!
skater.gif Successfully added to the gallery!
index.html Successfully added to the gallery!
Installation finished. Important: Please read README.TXT and manual for further settings.

Upload universal - Failed
Fatal: Installer error with /home/jplagard/public_html/avemux/media/install_46bb488e9c028/com_comprofiler/comprofiler.xml: component com_comprofiler SQL error DB function failed with error number 1064
You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'NOTEXISTS `mos_comprofiler_members` (`referenceid` int(11) NOT NULL default '0',' at line 1 SQL=CREATE TABLE IF NOTEXISTS `mos_comprofiler_members` (`referenceid` int(11) NOT NULL default '0',`memberid` int(11) NOT NULL default '0',`accepted` tinyint(1) NOT NULL default '1',`pending` tinyint(1) NOT NULL default '0',`membersince` date NOT NULL default '0000-00-00',`description` varchar(255) default NULL,`type` MEDIUMTEXT default NULL,PRIMARY KEY (`referenceid`,`memberid`)) TYPE=MyISAM ;
SQL =
CREATE TABLE IF NOTEXISTS `mos_comprofiler_members` (`referenceid` int(11) NOT NULL default '0',`memberid` int(11) NOT NULL default '0',`accepted` tinyint(1) NOT NULL default '1',`pending` tinyint(1) NOT NULL default '0',`membersince` date NOT NULL default '0000-00-00',`description` varchar(255) default NULL,`type` MEDIUMTEXT default NULL,PRIMARY KEY (`referenceid`,`memberid`)) TYPE=MyISAM ;

Information: Joomla/Mambo Community Builder 1.1 for Joomla! 1.0, 1.5 RC1 and Mambo 4.5.2 - 4.6.2.
[ Continue ... ]

EDIT: Changed title and made thread sticky.

Post edited by: beat, at: 2007/08/11 13:29

Please Log in to join the conversation.

13 years 10 months ago #42417 by beat
Replied by beat on topic Re:Error On Clean Install
Please read sticky in CB 1.0.2 bugs forum, and report bug more precisely...version numbers, etc....

Beat - Community Builder Team Member

Before posting on forums: Read FAQ thoroughly -- Help us spend more time coding by helping others in this forum, many thanks :)
CB links: Our membership - CBSubs - Templates - Hosting - Forge - Send me a Private Message (PM) only for private/confidential info

Please Log in to join the conversation.

13 years 10 months ago #42438 by jplagarde
Replied by jplagarde on topic Re:Error On Clean Install
I read the stick but didn't see anything that seemed to relate to my problem.

I use hostgator with Mambo 4.6.2. I really just built the site, downloaded the CB 1.0.2, and then found out about the compatability issues. So when CB 1.1 came out, since I only had a few users, i copied my template and my content and just erased my installation of Mambo and the SQL database that supported it. I then freshly installed Mambo and the system created a new SQL database for it. I downloaded CB 1.1, used the universal installer to install the com_comprofiler.zip and i got the above mentioned error that i started the thread with. Please let me know if you need anymore information. Thank you so much!!!

Please Log in to join the conversation.

13 years 10 months ago #42570 by beat
Replied by beat on topic Re:Error On Clean Install
Thanks for feedback, we will need to try to reproduce.

Did anybody else have this problem ?

Beat - Community Builder Team Member

Before posting on forums: Read FAQ thoroughly -- Help us spend more time coding by helping others in this forum, many thanks :)
CB links: Our membership - CBSubs - Templates - Hosting - Forge - Send me a Private Message (PM) only for private/confidential info

Please Log in to join the conversation.

13 years 10 months ago #42580 by bruce
Replied by bruce on topic Re:Error On Clean Install
Yes, I had exactly the same problem.

Thanks

Please Log in to join the conversation.

13 years 10 months ago #42589 by beat
Replied by beat on topic Re:Error On Clean Install
EDIT:

Please see and apply solution from Al Warren from Mambo core team proposed here:

www.joomlapolis.com/component/option,com_joomlaboard/Itemid,38/func,view/catid,41/id,48859/#48859

instead of the solution initially posted here, left for reference below.



INITIAL POST (THIS FIX TRIGGERED ANOTHER ADMIN MENU BUG IN MAMBO):


Ok analysed the problem. If you notice there is a missing space in the query between NOT and EXISTS. This is because it's a longer data content in the XML file and parsexml of PHP cuts every 256 chars the xml data.

There is a bug in the XML parser of Mambo 4.6.2: mambo trims each 256 chars the xml data...

Here is the fix for that bug:

in administrator/admin.php, lines 117-120:

change:

[code:1]
function character_data ($parser, $data) {
if ($this->errors->getMaxLevel() >= _MOS_ERROR_FATAL) return;
$this->chardata .= trim($data);
}
[/code:1]

by:

[code:1]
function character_data ($parser, $data) {
if ($this->errors->getMaxLevel() >= _MOS_ERROR_FATAL) return;
$this->chardata .=$data;
}
[/code:1]

Please check that the fix works for you... You need to fix this, uninstall and reinstall CB, that install should then work :)

(funily, Joomla 1.5 beta parsers had exactly the same bug, and I had to submit same fix :D ).

Post edited by: beat, at: 2007/10/27 15:51

Beat - Community Builder Team Member

Before posting on forums: Read FAQ thoroughly -- Help us spend more time coding by helping others in this forum, many thanks :)
CB links: Our membership - CBSubs - Templates - Hosting - Forge - Send me a Private Message (PM) only for private/confidential info

Please Log in to join the conversation.

Moderators: beatnantkrileon
Time to create page: 0.430 seconds

Facebook Twitter LinkedIn