#142 Session expired... enable cookies.

13 years 6 months ago #82714 by elaperriere
Replied by elaperriere on topic Re: #142 Session expired... enable cookies.
beat wrote:

----

Hi elaperriere,
Your first post says issues were at registration ? was that on step 1 as above or also on step 2 ?

I'm not sure that your case is similar to the first post in the thread ;)

Please confirm when exactly you have that error: in step 1 or in step 2 ?

If different than above, please post or PM me site registration page url :)


#142


Hi Beat,

My issue was only on the registration form, the user hit "OK" then he gets the message. I am unable to give you the proper access at the moment to my test site but I should be able to get to it on saturday and send you a PM.

Note that on a local test server it is on "192.168.1.100/Test/" and that on my second test server the joomla installation is in " www.exemple.com/joomla " on my host site.

I'll get back to you shortly.

thanks.

Please Log in to join the conversation.

13 years 6 months ago #82751 by skittle
Replied by skittle on topic Re:#142 Session expired... enable cookies.
I am using CB 1.2 RC4 with Joomla 1.5. I have been experiencing the same "session expired" message on login as described here. After trying everything I could find listed on this forum to resolve the issue with no success I finally read the recent post that mentioned SEF settings.

I was using the standard Joomla SEF configuration. I went to the Joomla admin back-end and turned off SEF. Voila, that allowed me to use the CBlogin module and successfully login without error.

The question is...

Can I do something now to allow CBlogin to work properly while SEF is enabled or is this something I have to work around until a patch is issued?

I would really like to have SEF enabled and use CB. (of course like everyone, I want my cake and eat it too.)

Thank you in advance for any insight (I am happy to provide any additional information that may be useful).

Skittle

Please Log in to join the conversation.

13 years 6 months ago #82755 by beat
elaperriere wrote:

beat wrote:

----

Hi elaperriere,
Your first post says issues were at registration ? was that on step 1 as above or also on step 2 ?

I'm not sure that your case is similar to the first post in the thread ;)

Please confirm when exactly you have that error: in step 1 or in step 2 ?

If different than above, please post or PM me site registration page url :)


#142


Hi Beat,

My issue was only on the registration form, the user hit "OK" then he gets the message. I am unable to give you the proper access at the moment to my test site but I should be able to get to it on saturday and send you a PM.

Note that on a local test server it is on "192.168.1.100/Test/" and that on my second test server the joomla installation is in " www.exemple.com/joomla " on my host site.

I'll get back to you shortly.

thanks.


Ok, thanks.

Btw there is no "Ok" button on registration or login form or in CB anywhere, so still wondering which button you hit immediately before getting that message....

Beat - Community Builder Team Member

Before posting on forums: Read FAQ thoroughly -- Help us spend more time coding by helping others in this forum, many thanks :)
CB links: Our membership - CBSubs - Templates - Hosting - Forge - Send me a Private Message (PM) only for private/confidential info

Please Log in to join the conversation.

13 years 6 months ago #82756 by beat
skittle wrote:

I am using CB 1.2 RC4 with Joomla 1.5. I have been experiencing the same "session expired" message on login as described here. After trying everything I could find listed on this forum to resolve the issue with no success I finally read the recent post that mentioned SEF settings.

I was using the standard Joomla SEF configuration. I went to the Joomla admin back-end and turned off SEF. Voila, that allowed me to use the CBlogin module and successfully login without error.

The question is...

Can I do something now to allow CBlogin to work properly while SEF is enabled or is this something I have to work around until a patch is issued?

I would really like to have SEF enabled and use CB. (of course like everyone, I want my cake and eat it too.)

Thank you in advance for any insight (I am happy to provide any additional information that may be useful).

Skittle


Please read my post on page 2:

It's also easily worked around with a "first login welcome page" that you can set in CB configuration -> registration tab in backend.

Beat - Community Builder Team Member

Before posting on forums: Read FAQ thoroughly -- Help us spend more time coding by helping others in this forum, many thanks :)
CB links: Our membership - CBSubs - Templates - Hosting - Forge - Send me a Private Message (PM) only for private/confidential info

Please Log in to join the conversation.

13 years 6 months ago #82758 by mtk
beat wrote:

It's also easily worked around with a "first login welcome page" that you can set in CB configuration -> registration tab in backend.

I'm sorry Beat, but I have to ask:
why did you decide this is the best way to solve the problem?
this is obviously not close to being the Joomla-Way, and not even complying with the old CB-Way.

first login, should go to the main page of the site without any session/error on the way...
what if I don't want any strange message/notification?

Please Log in to join the conversation.

13 years 6 months ago #82761 by beat
mtk,

I'm offering to skittle and you an easy work-around solution UNTIL we fix that bug in CB 1.2 Stable. If you have a simpler or better way to workaround this CB 1.2 RC 4 bug without code edit or a code fix, please propose, we are still in RC :) .

You can put "index.php" into first-page-login-URL in CB config to make it work fine with SEF in CB 1.2 RC 4.

CB 1.2 Stable will fix this "cosmetic" issue, which appears ONLY in NO email confirmation and NO approval mode and NO welcome page at first login mode, which is rather rare. Actually making any of these YES is another "workaround" for RC4.

I'm still waiting on elaperriere's confirmation to make sure that this thread contains 1 bug only.

Btw joomla and mambo do not redirect users loging-in to homepage, but stays on same page by default, including on first login, if it's not a registration-related page. That's also how CB normally behaves (except this bug).

Beat - Community Builder Team Member

Before posting on forums: Read FAQ thoroughly -- Help us spend more time coding by helping others in this forum, many thanks :)
CB links: Our membership - CBSubs - Templates - Hosting - Forge - Send me a Private Message (PM) only for private/confidential info

Please Log in to join the conversation.

Moderators: beatnantkrileon
Time to create page: 0.208 seconds

Facebook Twitter LinkedIn