#142 Session expired... enable cookies.

13 years 4 months ago #94223 by lordnukem
Replied by lordnukem on topic Re:#142 Session expired... enable cookies.
Hi Guys,

I'm having the same error on CB 1.2 and finally narrowed down the problem to the following.

1. Original site running on port 80. CB login & signup works flawlessly

2. Site & mysql db duplicated to run on port 8080 of the same server (for unit testing) and CB login and signup breaks with the infamous session expired error.

3. Site & mysql db duplicated to run on port 8085 of the same server (for unit testing) and CB login and signup breaks with the infamous session expired error.


4. Site & mysql db duplicated to run on port 8080 of a different server (testing server) (for unit testing) and CB login and signup breaks with the infamous session expired error.

5. Site & mysql db duplicated to run on port 8085 of a different server (testing server) (for unit testing) and CB login and signup breaks with the infamous session expired error.

6. Configured apache to run same site dump & sql db on port 80 of the testing server and CB login and signup works flawlessly again.

Looks to me CB login and signup having issues with port number in URL, or running on ports other than 80.

Can anyone confirm my finding and advice?
TQ

Please Log in to join the conversation.

13 years 4 months ago #94224 by beat
lordnukem wrote:

Hi Guys,

I'm having the same error on CB 1.2 and finally narrowed down the problem to the following.

1. Original site running on port 80. CB login & signup works flawlessly

2. Site & mysql db duplicated to run on port 8080 of the same server (for unit testing) and CB login and signup breaks with the infamous session expired error.

3. Site & mysql db duplicated to run on port 8085 of the same server (for unit testing) and CB login and signup breaks with the infamous session expired error.


4. Site & mysql db duplicated to run on port 8080 of a different server (testing server) (for unit testing) and CB login and signup breaks with the infamous session expired error.

5. Site & mysql db duplicated to run on port 8085 of a different server (testing server) (for unit testing) and CB login and signup breaks with the infamous session expired error.

6. Configured apache to run same site dump & sql db on port 80 of the testing server and CB login and signup works flawlessly again.

Looks to me CB login and signup having issues with port number in URL, or running on ports other than 80.

Can anyone confirm my finding and advice?
TQ


Did you add that port number in your live_site in configuration.php if runing joomla 1.0 ?

Usually cookies issues are bound to wrong domains...as they are depending on them.

Beat - Community Builder Team Member

Before posting on forums: Read FAQ thoroughly -- Help us spend more time coding by helping others in this forum, many thanks :)
CB links: Our membership - CBSubs - Templates - Hosting - Forge - Send me a Private Message (PM) only for private/confidential info

Please Log in to join the conversation.

13 years 4 months ago #94225 by lordnukem
Replied by lordnukem on topic Re:#142 Session expired... enable cookies.
beat wrote:

lordnukem wrote:

Hi Guys,

I'm having the same error on CB 1.2 and finally narrowed down the problem to the following.

1. Original site running on port 80. CB login & signup works flawlessly

2. Site & mysql db duplicated to run on port 8080 of the same server (for unit testing) and CB login and signup breaks with the infamous session expired error.

3. Site & mysql db duplicated to run on port 8085 of the same server (for unit testing) and CB login and signup breaks with the infamous session expired error.


4. Site & mysql db duplicated to run on port 8080 of a different server (testing server) (for unit testing) and CB login and signup breaks with the infamous session expired error.

5. Site & mysql db duplicated to run on port 8085 of a different server (testing server) (for unit testing) and CB login and signup breaks with the infamous session expired error.

6. Configured apache to run same site dump & sql db on port 80 of the testing server and CB login and signup works flawlessly again.

Looks to me CB login and signup having issues with port number in URL, or running on ports other than 80.

Can anyone confirm my finding and advice?
TQ


Did you add that port number in your live_site in configuration.php if runing joomla 1.0 ?

Usually cookies issues are bound to wrong domains...as they are depending on them.


I'm running Joomla 1.5 for all installations. I did tried the live site settings but still same result.

Please Log in to join the conversation.

13 years 4 months ago #94232 by Rapunzl
Replied by Rapunzl on topic Re:#142 Session expired... enable cookies.
Try upgrading to 1.2 Stable.

Jamie (Rapunzl)
Community Builder Team Member

Before posting on forums: Read all CB Articles | Specially the FAQ | Help us help you
CB links: Subscribe to CB documentation | [url=http://www.joomlapolis.com/content/view/7363/37/
]Our templates[/url] | [url=http://www.joomlapolis.com/content/blogcategory/61/74/
]Paid Subscriptions[/url] | Get Hosting | Our Forge
Visit my CB Profile

My personal site Rapunzl's Reality always under reconstruction

Please Log in to join the conversation.

13 years 4 months ago #94234 by lordnukem
Replied by lordnukem on topic Re:#142 Session expired... enable cookies.
Rapunzl wrote:

Try upgrading to 1.2 Stable.


Hi Rapunzl,

I am on 1.2 stable for all installations.

just to recap, I am running

PHP 5.1.6 (cli) (built: Jul 16 2008 19:53:00)
Joomla 1.5.9
CB 1.2 Stable

Server A:80 = CB Signup works.
Server A:8080 = CB Signup broken with session expired
Server A:8085 = CB Signup broken with session expired

Server B:80 = CB Signup works.
Server B:8080 = CB Signup broken with session expired
Server B:8085 = CB Signup broken with session expired.

on all 6 scenarios I have
1. copy site and db into new folder & database
2. use port 80 folder but redirect apache to host at 8080 & 8085
3. Put in appropriate url in $live_site in configuration.php

Cheers,
Eddie

Post edited by: lordnukem, at: 2009/04/08 05:43

Please Log in to join the conversation.

13 years 3 months ago #94958 by someguyiknow12
Replied by someguyiknow12 on topic Re:#142 Session expired... enable cookies.
Issue same here, I have come across this issue before, that was with Joomla 1.0.13 // Now today I run Joomla Version 1.5.10 // I have done these few things to help narrow this issue.

Shared Server
MySql 5.0
Php5
Joomla 1.5.10
CB 1.2 (downloaded today-again)
__
A few plug ins.
__
So how I got to this issue: It worked before I hadn't installed anything new, I am not new to Joomla as mentioned earlier, I viewed SEF being the issue,turned it off. Reverted back to default htaccess.txt

Cleaned MYSQL DB of CB / Uninstalled all CB com,mod,plugins ect..

Issue continues.

Now with Joomla basic login works fine.
With CB login doesn't work.

With both enabled (Joomla login & CB login) Login using the Joomla based, ables to login -
Results:
img22.imageshack.us/my.php?image=cbloginform.jpg
___
When you login to the top box (CB) it gets
( Session expired or cookies are not enabled in your browser. Please press "reload page" in your browser, and enable cookies in your browser. Please refresh/reload page before filling-in. )
___

So when I log out - (if logged in with CB) Then remove the Joomla login////Try to log out/// It goes to: "Session expired or cookies - error"..
__
So for some odd reason after the testing doesn't make sense because you want to blame it on other COM or MODS but truly simply is the fact that it's the CB MOD login, how I don't know.

Can I recreate it - not sure.
Feels as though the cookie is not being carried over. Why? I'm not that good that's where BEAT comes in do0d - help us please haha.

P.S. Friend registered won the website,so registration works great/its the mod_login

Post edited by: someguyiknow12, at: 2009/04/15 05:57

Please Log in to join the conversation.

Moderators: beatnantkrileon
Time to create page: 0.262 seconds

Facebook Twitter LinkedIn